Exhaust manifold to downpipe flange keeps blowing

Go down

Exhaust manifold to downpipe flange keeps blowing

Post by Chas Uno on Thu Apr 17, 2014 7:04 am

I'm having a recurring problem with my 1500 X19 engine Uno 70SX. Despite using new nuts, new gasket and making sure all is tight, the downpipe to exhaust manifold flange keeps blowing after a few hundred miles. It's not the nuts coming loose as I'm using lock plates, so they aren't moving. However, when I try and tighten up the nuts (after releasing the lock plates) the nuts all appear to be a little loose. I can tighten them up again and that solves the problem for the next few hundred miles and then the damn thing blows again...

I've changed the nuts a few times, and it looks like they become slightly distorted when used. I'm wondering if the brass nuts are too soft for the manifold flange? I never had this problem with the same exhaust on the original 1301cc engine, though I think I was using steel nuts on that.

What nuts does everyone else used for their exhaust manifold to downpipe flange? And what do you use for locking plates (mine are starting to get a little tired after being used so many times)?

These are the nuts I've been using:

http://www.eurosport-uk.net/shop/index.php?main_page=product_info&cPath=1_8&products_id=47

Many thanks for any advice.
avatar
Chas Uno
4th gear
4th gear

Posts : 189
Join date : 2013-03-01
Location : NW London

View user profile

Back to top Go down

Re: Exhaust manifold to downpipe flange keeps blowing

Post by Mintys-turbo-mk1 on Sat Apr 19, 2014 5:23 am

posted the pic on facebook.
Ben
avatar
Mintys-turbo-mk1
5th gear
5th gear

Posts : 307
Join date : 2013-01-28
Age : 33
Location : Stowmarket

View user profile

Back to top Go down

Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum